Medium severity · published Mar 23, 2021
CVE-2021-21338
TYPO3 is an open source PHP based web content management system
6.1
CVSS
1.1%
EPSS
No
On KEV
Description
TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 6.2.57, 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1 it has been discovered that Login Handling is susceptible to open redirection which allows attackers redirecting to arbitrary content, and conducting phishing attacks. No authentication is required in order to exploit this vulnerability. This is fixed in versions 6.2.57, 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)1.1% · higher than 66% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
TY
Typo3 · Typo3
6.2.0 before 6.2.57; 7.0.0 before 7.6.51; 8.0.0 before 8.7.40; 9.0.0 before 9.5.25; 10.0.0 before 10.4.14; 11.0.0 before 11.1.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2021-21338
CVE.org
https://www.cve.org/CVERecord?id=CVE-2021-21338
Third Party Advisory
https://github.com/TYPO3/TYPO3.CMS/security/advisories/GHSA-4jhw-2p6j-5wmp
Release Notes
https://packagist.org/packages/typo3/cms-core
Vendor Advisory
https://typo3.org/security/advisory/typo3-core-sa-2021-001
More from Typo3
10.0
CVE-2020-11066
In TYPO3 CMS greater than or equal to 9.0.0 and less than 9.5.17 and greater than or equal to 10.0.0 and less than 10.4.2, calling unserialize() on malicious user-submitted…
9.8
CVE-2024-45233
An issue was discovered in powermail extension through 12.3.5 for TYPO3
9.8
CVE-2011-3583
It was found that Typo3 Core versions 4.5.0 - 4.5.5 uses prepared statements that, if the parameter values are not properly replaced, could lead to a SQL Injection vulnerability
9.8
CVE-2011-4628
TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to bypass authentication mechanisms in the backend through a crafted request
8.8
CVE-2025-59017
Broken Access Control in Backend AJAX Routes
