High severity · published Feb 24, 2020
CVE-2020-5244
In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed
7.5
CVSS
2.4%
EPSS
No
On KEV
Description
In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed. This has been patched in version 5.1.2.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.4% · higher than 84% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
BU
Buddypress · Buddypress
5.0.0 before 5.1.2 · source: NVD
Affected product
BU
Buddypress
Buddypress
More from Buddypress
8.8
CVE-2021-21389
BuddyPress is an open source WordPress plugin to build a community site
8.5
CVE-2026-115965
WordPress BuddyPress plugin <= 14.5.2 - SQL Injection vulnerability
8.5
CVE-2026-111850
WordPress BuddyPress plugin <= 14.5.2 - SQL Injection vulnerability
8.1
CVE-2026-53673
BuddyPress 14.4.0 Private Message IDOR via REST API user_id Parameter
8.1
CVE-2024-10011
BuddyPress <= 14.1.0 - Authenticated (Subscriber+) Directory Traversal