High severity · published Dec 8, 2020
CVE-2020-25630
A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could lead to a denial of…
7.5
CVSS
1.4%
EPSS
No
On KEV
Description
A vulnerability was found in Moodle where the decompressed size of zip files was not checked against available user quota before unzipping them, which could lead to a denial of service risk. This affects versions 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. Fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.4% · higher than 72% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
MO
Moodle · Moodle
3.5.0 before 3.5.14; 3.7.0 before 3.7.8; 3.8.0 before 3.8.5; 3.9.0 before 3.9.2 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2020-25630
CVE.org
https://www.cve.org/CVERecord?id=CVE-2020-25630
Patch
https://moodle.org/mod/forum/discuss.php?d=410842
More from Moodle
10.0
CVE-2019-3809
A flaw was found in Moodle versions 3.1 to 3.1.15 and earlier unsupported versions
9.8
CVE-2025-67856
Moodle: moodle: privilege escalation via incomplete role checks in badge awarding
9.8
CVE-2025-26533
SQL injection risk in course search module list filter
9.8
CVE-2024-33999
moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php
9.8
CVE-2023-5550
Moodle: rce due to lfi risk in some misconfigured shared hosting environments
